Magento 2 Conflict Detector Extension Documentation

 This is a documentation for the Conflict Detector for Magento 2  y Magefan.

  1. Conflict Detector for Magento 2 Installation

    To install Conflict Detector for Magento 2  by Magefan, please use one of these installation methods.

    Installation Method 1 - Installing via Composer (recommended)

    1. Open command line
    2. Using command "cd" navigate to your Magento 2 root directory
    3. Run CLI commands:
    composer require magefan/module-conflict-detector
    # Authentication required (repo.magento.com)
    # Get your Magento Marketplace authentication keys or use these:
    # Username: 7c018006799466c681ad507e27904677
    # Password: 289077c86e811661a8f7751828485d3a
    php bin/magento setup:upgrade
    php bin/magento setup:di:compile
    php bin/magento setup:static-content:deploy

    Read more »
  2. Uninstalling Magefan Conflict Detector for Magento 2

    If you decided to remove Conflict Detector for Magento 2 by Magefan, please follow the steps below, also you can contact our team for a free consultation in case you have any issues with Magefan's extension.

    Remove Extension Files

    Removing files instruction depends on a way the extension has been installed.

    1. If you can find the extension files in the folder

    app/code/Magefan/ConflictDetector

    then remove this folder.

    2. If the extension was installed via the composer and its files located in the folder

    vendor/magefan/module-conflict-detector

    then run composer CLI command to remove it

    composer remove magefan/module-conflict-detector

    Read more »
  3. Updating Magefan Conflict Detector

    If you need to update Conflict Detector for Magento 2 by Magefan, please follow the steps below. Note that the update instructions depend on the method conflict detector extension was installed with.

    Update using composer

    If the conflict detector module was installed via the composer (check if vendor/magefan/module-conflict-detector folder exists), then you need to run these simple CLI commands in Magento 2 directory:

    composer remove magefan/module-conflict-detector
    composer require magefan/module-conflict-detector ^x.x.x
    # replace x.x.x with the version you want to use
    php bin/magento setup:upgrade
    php bin/magento setup:di:compile
    php bin/magento setup:static-content:deploy

     Update using FTP

    If the conflict detector module was installed via

    Read more »
^Top
Chat